#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[-_]"
Local $sString = "section_d1_2010-07-01_08_00.txt"
Local $sSubst = "\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)