use strict;
my $str = 'section_d1_2010-07-01_08_00.txt';
my $regex = qr/[-_]/p;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";