package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[-_]`)
var str = `section_d1_2010-07-01_08_00.txt`
var substitution = "\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}