$re = '/[-_]/';
$str = 'section_d1_2010-07-01_08_00.txt';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;