using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[-_]";
string substitution = @"\n";
string input = @"section_d1_2010-07-01_08_00.txt";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}