#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(.{3,})\:\/\/(.+\.)(\w{2,})?(?:(\/.+)?(\?.+)(\#.+)|(\/.+)(\?.+)|(\/.+))?"
Local $sString = "http://www.google.com/path/path2/path3/site.php?arg=1&fafa=2#fragment" & @CRLF & _
"https://subdomain.secondlevel.gg/path?arg=1" & @CRLF & _
"ftp://ftp.interwebs.com/path" & @CRLF & _
"http://www.google.com" & @CRLF & _
"bitcoin:1HdHcvkMgUaMv2KypF8u9RSxqL57WbY1R6 <-- current version doesn't match such URIs."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")