import re
regex = re.compile(r"(.{3,})\:\/\/(.+\.)(\w{2,})?(?:(\/.+)?(\?.+)(\#.+)|(\/.+)(\?.+)|(\/.+))?")
test_str = ("http://www.google.com/path/path2/path3/site.php?arg=1&fafa=2#fragment\n"
"https://subdomain.secondlevel.gg/path?arg=1\n"
"ftp://ftp.interwebs.com/path\n"
"http://www.google.com\n"
"bitcoin:1HdHcvkMgUaMv2KypF8u9RSxqL57WbY1R6 <-- current version doesn't match such URIs.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")