import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.{3,})\\:\\/\\/(.+\\.)(\\w{2,})?(?:(\\/.+)?(\\?.+)(\\#.+)|(\\/.+)(\\?.+)|(\\/.+))?";
final String string = "http://www.google.com/path/path2/path3/site.php?arg=1&fafa=2#fragment\n"
+ "https://subdomain.secondlevel.gg/path?arg=1\n"
+ "ftp://ftp.interwebs.com/path\n"
+ "http://www.google.com\n"
+ "bitcoin:1HdHcvkMgUaMv2KypF8u9RSxqL57WbY1R6 <-- current version doesn't match such URIs.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}