re = /(.{3,})\:\/\/(.+\.)(\w{2,})?(?:(\/.+)?(\?.+)(\#.+)|(\/.+)(\?.+)|(\/.+))?/
str = 'http://www.google.com/path/path2/path3/site.php?arg=1&fafa=2#fragment
https://subdomain.secondlevel.gg/path?arg=1
ftp://ftp.interwebs.com/path
http://www.google.com
bitcoin:1HdHcvkMgUaMv2KypF8u9RSxqL57WbY1R6 <-- current version doesn\'t match such URIs.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end