using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.{3,})\:\/\/(.+\.)(\w{2,})?(?:(\/.+)?(\?.+)(\#.+)|(\/.+)(\?.+)|(\/.+))?";
string input = @"http://www.google.com/path/path2/path3/site.php?arg=1&fafa=2#fragment
https://subdomain.secondlevel.gg/path?arg=1
ftp://ftp.interwebs.com/path
http://www.google.com
bitcoin:1HdHcvkMgUaMv2KypF8u9RSxqL57WbY1R6 <-- current version doesn't match such URIs.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}