use strict;
my $str = 'http://www.google.com/path/path2/path3/site.php?arg=1&fafa=2#fragment
https://subdomain.secondlevel.gg/path?arg=1
ftp://ftp.interwebs.com/path
http://www.google.com
bitcoin:1HdHcvkMgUaMv2KypF8u9RSxqL57WbY1R6 <-- current version doesn\'t match such URIs.';
my $regex = qr/(.{3,})\:\/\/(.+\.)(\w{2,})?(?:(\/.+)?(\?.+)(\#.+)|(\/.+)(\?.+)|(\/.+))?/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}