const regex = new RegExp('(.{3,})\\:\\/\\/(.+\\.)(\\w{2,})?(?:(\\/.+)?(\\?.+)(\\#.+)|(\\/.+)(\\?.+)|(\\/.+))?', 'g')
const str = `http://www.google.com/path/path2/path3/site.php?arg=1&fafa=2#fragment
https://subdomain.secondlevel.gg/path?arg=1
ftp://ftp.interwebs.com/path
http://www.google.com
bitcoin:1HdHcvkMgUaMv2KypF8u9RSxqL57WbY1R6 <-- current version doesn't match such URIs.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}