#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(?=\[(!\[.+?\]\(.+?\)|.+?)]\(((https|http):\/\/[^\)]+)\))"
Local $sString = "#Regex for images and links" & @CRLF & _
"" & @CRLF & _
"## Links" & @CRLF & _
"" & @CRLF & _
"[example 1](https://example.com)" & @CRLF & _
"This [link](https://example2.com) is inline" & @CRLF & _
"" & @CRLF & _
"## Images" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"[](http://link.com)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")