re = /(?=\[(!\[.+?\]\(.+?\)|.+?)]\(((https|http):\/\/[^\)]+)\))/i
str = '#Regex for images and links
## Links
[example 1](https://example.com)
This [link](https://example2.com) is inline
## Images


[](http://link.com)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end