$re = '/(?=\[(!\[.+?\]\(.+?\)|.+?)]\(((https|http):\/\/[^\)]+)\))/i';
$str = '#Regex for images and links
## Links
[example 1](https://example.com)
This [link](https://example2.com) is inline
## Images


[](http://link.com)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);