const regex = /(?=\[(!\[.+?\]\(.+?\)|.+?)]\(((https|http):\/\/[^\)]+)\))/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=\\[(!\\[.+?\\]\\(.+?\\)|.+?)]\\(((https|http):\\\/\\\/[^\\)]+)\\))', 'gi')
const str = `#Regex for images and links
## Links
[example 1](https://example.com)
This [link](https://example2.com) is inline
## Images


[](http://link.com)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}