using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"'[\w ]+\$[\w]+[\w ]+'";
string input = @"$var = 'Hello world!';
echo 'Lorem ipsum $var dolor sit amet'; // Match this.
echo ""Lorem ipsum 'dolor sit amet $var consectetur' adipiscing elit""; // But not this.
echo ""Lorem ipsum 'dolor sit amet \$var consectetur' adipiscing elit""; // Or this.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}