import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "'[\\w ]+\\$[\\w]+[\\w ]+'";
final String string = "$var = 'Hello world!';\n\n"
+ "echo 'Lorem ipsum $var dolor sit amet'; // Match this.\n"
+ "echo \"Lorem ipsum 'dolor sit amet $var consectetur' adipiscing elit\"; // But not this.\n"
+ "echo \"Lorem ipsum 'dolor sit amet \\$var consectetur' adipiscing elit\"; // Or this.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}