$re = '/\'[\w ]+\$[\w]+[\w ]+\'/';
$str = '$var = \'Hello world!\';
echo \'Lorem ipsum $var dolor sit amet\'; // Match this.
echo "Lorem ipsum \'dolor sit amet $var consectetur\' adipiscing elit"; // But not this.
echo "Lorem ipsum \'dolor sit amet \\$var consectetur\' adipiscing elit"; // Or this.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);