package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`'[\w ]+\$[\w]+[\w ]+'`)
var str = `$var = 'Hello world!';
echo 'Lorem ipsum $var dolor sit amet'; // Match this.
echo "Lorem ipsum 'dolor sit amet $var consectetur' adipiscing elit"; // But not this.
echo "Lorem ipsum 'dolor sit amet \$var consectetur' adipiscing elit"; // Or this.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}