re = /'[\w ]+\$[\w]+[\w ]+'/
str = '$var = \'Hello world!\';
echo \'Lorem ipsum $var dolor sit amet\'; // Match this.
echo "Lorem ipsum \'dolor sit amet $var consectetur\' adipiscing elit"; // But not this.
echo "Lorem ipsum \'dolor sit amet \\$var consectetur\' adipiscing elit"; // Or this.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end