using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b[A-Z]\w*(?:[^\S\n]+[A-Z]\w*)*(?:[^\S\n]+[a-z]\w*)*(?=:)";
string input = @"Title: Consectetur adipiscg elit Description: Sed sit
> amet eros diam Details: Vestibulum a eros ut massa interdum
> consectetur Article number: AYHMNR
Title tEST: testing
Big red car:1, Small green ship: 2, Green Forest:3";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}