use strict;
my $str = 'Title: Consectetur adipiscg elit Description: Sed sit
> amet eros diam Details: Vestibulum a eros ut massa interdum
> consectetur Article number: AYHMNR
Title tEST: testing
Big red car:1, Small green ship: 2, Green Forest:3';
my $regex = qr/\b[A-Z]\w*(?:[^\S\n]+[A-Z]\w*)*(?:[^\S\n]+[a-z]\w*)*(?=:)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}