re = /\b[A-Z]\w*(?:[^\S\n]+[A-Z]\w*)*(?:[^\S\n]+[a-z]\w*)*(?=:)/m
str = 'Title: Consectetur adipiscg elit Description: Sed sit
> amet eros diam Details: Vestibulum a eros ut massa interdum
> consectetur Article number: AYHMNR
Title tEST: testing
Big red car:1, Small green ship: 2, Green Forest:3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end