import re
regex = re.compile(r"\b[A-Z]\w*(?:[^\S\n]+[A-Z]\w*)*(?:[^\S\n]+[a-z]\w*)*(?=:)", flags=re.MULTILINE)
test_str = ("Title: Consectetur adipiscg elit Description: Sed sit\n"
"> amet eros diam Details: Vestibulum a eros ut massa interdum\n"
"> consectetur Article number: AYHMNR\n"
"Title tEST: testing\n"
"Big red car:1, Small green ship: 2, Green Forest:3")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")