import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b[A-Z]\\w*(?:[^\\S\\n]+[A-Z]\\w*)*(?:[^\\S\\n]+[a-z]\\w*)*(?=:)";
final String string = "Title: Consectetur adipiscg elit Description: Sed sit\n"
+ "> amet eros diam Details: Vestibulum a eros ut massa interdum\n"
+ "> consectetur Article number: AYHMNR\n"
+ "Title tEST: testing\n"
+ "Big red car:1, Small green ship: 2, Green Forest:3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}