using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\s){2,}|\s";
string substitution = @"$1";
string input = @"S O M E T E X T I W O U L D L I K E T O H I G H L I G H T";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}