import re
regex = re.compile(r"(\s){2,}|\s")
test_str = "S O M E T E X T I W O U L D L I K E T O H I G H L I G H T"
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)