package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\s){2,}|\s`)
var str = `S O M E T E X T I W O U L D L I K E T O H I G H L I G H T`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}