use strict;
my $str = 'S O M E T E X T I W O U L D L I K E T O H I G H L I G H T';
my $regex = qr/(\s){2,}|\s/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";