const regex = /(?<="name":)(?:\w+|"(?:.+|(?0))"|\[(?:.+|(?0))\]|{(?:[^{}]|(?0))*})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<="name":)(?:\\w+|"(?:.+|(?0))"|\\[(?:.+|(?0))\\]|{(?:[^{}]|(?0))*})', 'gm')
const str = `{"name":{"first":"ainsley","last":"clarke","coord":{"lat":100, "lng":200}},"0":["one","two","three"],"location":{"0":"usa"},"roles":["admin","super","csr"],"test":true,"age":34}
{"first":"ainsley","last":"clarke"}
{}
{"name":{}}
[]
{"age":29, "name":"jim"}
{"age":29, "name":["jim"]}
{"age":29, "name":[true]}
{"age":29, "name":true}
{"age":29, "name":false}
{"age":29, "name":null}
{"age":29, "name":undefined}
{"age":29, "name":NaN}
{"age":29, "name":{"first":"ainsley"}}
[true]
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}