import Foundation
let pattern = #"(?<="name":)(?:\w+|"(?:.+|(?0))"|\[(?:.+|(?0))\]|{(?:[^{}]|(?0))*})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
{"name":{"first":"ainsley","last":"clarke","coord":{"lat":100, "lng":200}},"0":["one","two","three"],"location":{"0":"usa"},"roles":["admin","super","csr"],"test":true,"age":34}
{"first":"ainsley","last":"clarke"}
{}
{"name":{}}
[]
{"age":29, "name":"jim"}
{"age":29, "name":["jim"]}
{"age":29, "name":[true]}
{"age":29, "name":true}
{"age":29, "name":false}
{"age":29, "name":null}
{"age":29, "name":undefined}
{"age":29, "name":NaN}
{"age":29, "name":{"first":"ainsley"}}
[true]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)