re = /(?<="name":)(?:\w+|"(?:.+|(?0))"|\[(?:.+|(?0))\]|{(?:[^{}]|(?0))*})/m
str = '{"name":{"first":"ainsley","last":"clarke","coord":{"lat":100, "lng":200}},"0":["one","two","three"],"location":{"0":"usa"},"roles":["admin","super","csr"],"test":true,"age":34}
{"first":"ainsley","last":"clarke"}
{}
{"name":{}}
[]
{"age":29, "name":"jim"}
{"age":29, "name":["jim"]}
{"age":29, "name":[true]}
{"age":29, "name":true}
{"age":29, "name":false}
{"age":29, "name":null}
{"age":29, "name":undefined}
{"age":29, "name":NaN}
{"age":29, "name":{"first":"ainsley"}}
[true]
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end