import re
regex = re.compile(r"(?<=\"name\":)(?:\w+|\"(?:.+|(?0))\"|\[(?:.+|(?0))\]|{(?:[^{}]|(?0))*})", flags=re.MULTILINE)
test_str = ("{\"name\":{\"first\":\"ainsley\",\"last\":\"clarke\",\"coord\":{\"lat\":100, \"lng\":200}},\"0\":[\"one\",\"two\",\"three\"],\"location\":{\"0\":\"usa\"},\"roles\":[\"admin\",\"super\",\"csr\"],\"test\":true,\"age\":34}\n\n"
"{\"first\":\"ainsley\",\"last\":\"clarke\"}\n"
"{}\n"
"{\"name\":{}}\n"
"[]\n"
"{\"age\":29, \"name\":\"jim\"}\n"
"{\"age\":29, \"name\":[\"jim\"]}\n"
"{\"age\":29, \"name\":[true]}\n"
"{\"age\":29, \"name\":true}\n"
"{\"age\":29, \"name\":false}\n"
"{\"age\":29, \"name\":null}\n"
"{\"age\":29, \"name\":undefined}\n"
"{\"age\":29, \"name\":NaN}\n"
"{\"age\":29, \"name\":{\"first\":\"ainsley\"}}\n"
"[true]\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")