# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\h.*|\D+//g;t' <<< "1234hello567u8 915 kl15"