using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\h.*|\D+";
string substitution = @"";
string input = @"1234hello567u8 915 kl15";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}