$re = '/\h.*|\D+/';
$str = '1234hello567u8 915 kl15';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;