package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\h.*|\D+`)
var str = `1234hello567u8 915 kl15`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}