#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\h.*|\D+"
Local $sString = "1234hello567u8 915 kl15"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)