use strict;
my $str = '1234hello567u8 915 kl15';
my $regex = qr/\h.*|\D+/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";