import Foundation
let pattern = #"\h.*|\D+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"1234hello567u8 915 kl15"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)