#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(@[\w]+)"
Local $sString = "James Morrow @pwafork" & @CRLF & _
"14 mins · Like" & @CRLF & _
"" & @CRLF & _
"Amy Holbrook @chivalress and it's a combination of serious shit, my dumb life, and curated Good Tweets" & @CRLF & _
"13 mins · Like" & @CRLF & _
"" & @CRLF & _
"Stefanie Elliott Cirillo I exist to harass Nick on Twitter" & @CRLF & _
"11 mins · Like" & @CRLF & _
"" & @CRLF & _
"Stefanie Elliott Cirillo J/k I'm @stefc and basically talk about my kids. I have hashtags such as #annaquoteoftheday and a new #veraquoteoctheday which is whatever hilarious thing my kids have said." & @CRLF & _
"10 mins · Like" & @CRLF & _
"" & @CRLF & _
"Bradley America @bradley_america" & @CRLF & _
"6 mins · Like"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")