import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(@[\\w]+)";
final String string = "James Morrow @pwafork\n"
+ "14 mins · Like\n\n"
+ "Amy Holbrook @chivalress and it's a combination of serious shit, my dumb life, and curated Good Tweets\n"
+ "13 mins · Like\n\n"
+ "Stefanie Elliott Cirillo I exist to harass Nick on Twitter\n"
+ "11 mins · Like\n\n"
+ "Stefanie Elliott Cirillo J/k I'm @stefc and basically talk about my kids. I have hashtags such as #annaquoteoftheday and a new #veraquoteoctheday which is whatever hilarious thing my kids have said.\n"
+ "10 mins · Like\n\n"
+ "Bradley America @bradley_america\n"
+ "6 mins · Like";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}