const regex = /(@[\w]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(@[\\w]+)', 'g')
const str = `James Morrow @pwafork
14 mins · Like
Amy Holbrook @chivalress and it's a combination of serious shit, my dumb life, and curated Good Tweets
13 mins · Like
Stefanie Elliott Cirillo I exist to harass Nick on Twitter
11 mins · Like
Stefanie Elliott Cirillo J/k I'm @stefc and basically talk about my kids. I have hashtags such as #annaquoteoftheday and a new #veraquoteoctheday which is whatever hilarious thing my kids have said.
10 mins · Like
Bradley America @bradley_america
6 mins · Like`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}