import re
regex = re.compile(r"(@[\w]+)")
test_str = ("James Morrow @pwafork\n"
"14 mins · Like\n\n"
"Amy Holbrook @chivalress and it's a combination of serious shit, my dumb life, and curated Good Tweets\n"
"13 mins · Like\n\n"
"Stefanie Elliott Cirillo I exist to harass Nick on Twitter\n"
"11 mins · Like\n\n"
"Stefanie Elliott Cirillo J/k I'm @stefc and basically talk about my kids. I have hashtags such as #annaquoteoftheday and a new #veraquoteoctheday which is whatever hilarious thing my kids have said.\n"
"10 mins · Like\n\n"
"Bradley America @bradley_america\n"
"6 mins · Like")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")