package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(@[\w]+)`)
var str = `James Morrow @pwafork
14 mins · Like
Amy Holbrook @chivalress and it's a combination of serious shit, my dumb life, and curated Good Tweets
13 mins · Like
Stefanie Elliott Cirillo I exist to harass Nick on Twitter
11 mins · Like
Stefanie Elliott Cirillo J/k I'm @stefc and basically talk about my kids. I have hashtags such as #annaquoteoftheday and a new #veraquoteoctheday which is whatever hilarious thing my kids have said.
10 mins · Like
Bradley America @bradley_america
6 mins · Like`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}