use strict;
my $str = 'James Morrow @pwafork
14 mins · Like
Amy Holbrook @chivalress and it\'s a combination of serious shit, my dumb life, and curated Good Tweets
13 mins · Like
Stefanie Elliott Cirillo I exist to harass Nick on Twitter
11 mins · Like
Stefanie Elliott Cirillo J/k I\'m @stefc and basically talk about my kids. I have hashtags such as #annaquoteoftheday and a new #veraquoteoctheday which is whatever hilarious thing my kids have said.
10 mins · Like
Bradley America @bradley_america
6 mins · Like';
my $regex = qr/(@[\w]+)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}