package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(<a [a-zA-Z="#\s'.,?а-яА-Я0-9:><;%$&\/]+\/a>)`)
var str = `<br>
<a href="https://yandex.ru/images/search?from=tabbar&text=кошки%20достоевского">Кошки Достоевского</a>
<a href="https://yandex.ru/images/search?from=tabbar&text=кошки%20достоевского">Кошки Достоевского</a>
Роман Фёдора Михайловича Достоевского, впервые опубликованный в номерах журнала «Русский вестник» за 1868 год. Являлся одним из самых любимых произведений писателя, наиболее полно выразившим и нравственно-философскую позицию Достоевского.
<a href="#" onClick='this.innerHTML==="1 " ? this.innerHTML="2 " : this.innerHTML="1 "'>1 </a>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}