// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r##"(?m)(<a [a-zA-Z="#\s'.,?а-яА-Я0-9:><;%$&\/]+\/a>)"##).unwrap();
let string = "<br>
<a href=\"https://yandex.ru/images/search?from=tabbar&text=кошки%20достоевского\">Кошки Достоевского</a>
<a href=\"https://yandex.ru/images/search?from=tabbar&text=кошки%20достоевского\">Кошки Достоевского</a>
Роман Фёдора Михайловича Достоевского, впервые опубликованный в номерах журнала «Русский вестник» за 1868 год. Являлся одним из самых любимых произведений писателя, наиболее полно выразившим и нравственно-философскую позицию Достоевского.
<a href=\"#\" onClick='this.innerHTML===\"1 \" ? this.innerHTML=\"2 \" : this.innerHTML=\"1 \"'>1 </a>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}