use strict;
my $str = '<br>
<a href="https://yandex.ru/images/search?from=tabbar&text=кошки%20достоевского">Кошки Достоевского</a>
<a href="https://yandex.ru/images/search?from=tabbar&text=кошки%20достоевского">Кошки Достоевского</a>
Роман Фёдора Михайловича Достоевского, впервые опубликованный в номерах журнала «Русский вестник» за 1868 год. Являлся одним из самых любимых произведений писателя, наиболее полно выразившим и нравственно-философскую позицию Достоевского.
<a href="#" onClick=\'this.innerHTML==="1 " ? this.innerHTML="2 " : this.innerHTML="1 "\'>1 </a>';
my $regex = qr/(<a [a-zA-Z="#\s'.,?а-яА-Я0-9:><;%$&\/]+\/a>)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}